doc2vec 구현 라이브러리

원래 doc2vec는 genim(https://radimrehurek.com/gensim/models/doc2vec.html)에서

구현 되어 있는데

저걸 어떤 능력자 분꼐서 keras 버젼으로 포팅(https://github.com/niitsuma/word2vec-keras-in-gensim) 개인적으로 theano나 tensorflow같은 그래프 기반 딥 러닝 라이브러리는 어려워서

keras버젼이 있다길래 좋다고 설치하고 이것 저것 돌려 봤는데..

cuda 3지원 안되는 그래픽 카드 때문에 자꾸 워링 메세지 발생(거슬려… 참고로 본인 그래픽 카드는 gtx460 cuda 2.1지원 ㅡㅡ)

keras가 백엔드로 theano, tensorflow 둘다 지원 되는데, tensorflow 백엔드 일때 이런 저런 오류 발생(아무래도 만든 아자씨가 theano로 만들었거나 tensorflow버젼이 안 맞는듯)

그냥 theano버젼을 쓰면 무난히 동작 할 것 같은데..

gensim에서 만든 vector representation과 keras로 만든 vector representation이 달라서 애매… 뭐 좀 다를수도 있지 싶은데…

애매해서 그냥 gensim으로 기사 수집해 놓은거 다시 돌려봄..

 

답글 남기기

이메일은 공개되지 않습니다. 필수 입력창은 * 로 표시되어 있습니다.