태그 보관물: libstdc++

맥 mojave jpype 설치 오류 해결

Published / by greennuri

맥 새 OS mojave에서

더 정확히 이야기 하면 XCode10을 쓰는 환경에서 python 패키지중 gcc를 통해 컴파일 하는 패키지가 잘 설치 되지 않습니다.

이유는 다음과 같습니다

Building with libstdc++ was deprecated with Xcode 8 and is not supported in Xcode 10 when targeting iOS.

xcode10에서는 libstdc++을 더이상 지원하지 않습니다.

해결 책은 libstdc++이 아니라 libc++을 이용해서 컴파일하게 명령을 내리면 됩니다.

저 같은 jpype1을 설치 하면서 삽질을 했는데요 ^^

기존에 jpype1설치는 “pip install jpype1″으로 하면 되는데

mojave에서는 다음과 같이 하면 됩니다 .

‘CFLAGS=”-stdlib=libc++” pip install jpype1’

 

지금까지 위 사항에 영향을 받는 패키지는 jpype, mecab-python3 두개가 확인 됐네요